summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/brasero')
-rw-r--r--app-cdr/brasero/Manifest2
-rw-r--r--app-cdr/brasero/brasero-3.12.0.ebuild80
-rw-r--r--app-cdr/brasero/brasero-3.12.1.ebuild80
-rw-r--r--app-cdr/brasero/metadata.xml17
4 files changed, 179 insertions, 0 deletions
diff --git a/app-cdr/brasero/Manifest b/app-cdr/brasero/Manifest
new file mode 100644
index 000000000000..8bc336ab6a9d
--- /dev/null
+++ b/app-cdr/brasero/Manifest
@@ -0,0 +1,2 @@
+DIST brasero-3.12.0.tar.xz 3652832 SHA256 68fef2699b772fa262d855dac682100dbfea05563a7e4056eff8fe6447aec2fc SHA512 d8e40bc505d7bb77b1c74914895a8ccfd2a8773e5a86fe0d4ae2625710fc56a654cf125e7799d4bd1e4d38e1d8a255de3c9f028ce1b770c163dff2033fb662d2 WHIRLPOOL adc1d3d773679a1ca0b76031a8065d8e2d7447eb94db595bfbe5e33226b5f189166781b33718337f489baf9fbb9e1d0adc14410a0c2060aeeebe073020f82029
+DIST brasero-3.12.1.tar.xz 3683836 SHA256 9a5eea53e57b66de3c7c8c2393ac21a58d5afa81c6cfb16b3c7f010a3d147127 SHA512 c9a78b9bc627f4420f5cf70825aa8de6e42497e63e293a0382916c9cd1a2bb3ae0beb2b95b624b7203ab17dfd8c8bb10c18c16848079b82077663abe34674eda WHIRLPOOL d7a5cd528d2c7ab37c5adeaf894646c989a29d806f6384e3a3cbcc6044785905f80907b9dec32e8228ade8558c227fe6ecbccf4bc0871e6d7a1581300a0e0550
diff --git a/app-cdr/brasero/brasero-3.12.0.ebuild b/app-cdr/brasero/brasero-3.12.0.ebuild
new file mode 100644
index 000000000000..86eeaf1a3949
--- /dev/null
+++ b/app-cdr/brasero/brasero-3.12.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Brasero"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/libnotify-0.6.1:=
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libICE
+ x11-libs/libSM
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ libburn? (
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.90 )
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-0.12:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-themes/hicolor-icon-theme
+ css? ( media-libs/libdvdcss:1.2 )
+ !libburn? (
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ virtual/cdrtools )
+ mp3? (
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-mad:1.0 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
+# eautoreconf deps
+# app-text/yelp-tools
+# gnome-base/gnome-common
+
+PDEPEND="gnome-base/gvfs"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/app-cdr/brasero/brasero-3.12.1.ebuild b/app-cdr/brasero/brasero-3.12.1.ebuild
new file mode 100644
index 000000000000..a3bf45af556b
--- /dev/null
+++ b/app-cdr/brasero/brasero-3.12.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD/DVD burning application for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Brasero"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0/3.1" # subslot is 3.suffix of libbrasero-burn3
+IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/libnotify-0.6.1:=
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libICE
+ x11-libs/libSM
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ libburn? (
+ >=dev-libs/libburn-0.4:=
+ >=dev-libs/libisofs-0.6.4:= )
+ nautilus? ( >=gnome-base/nautilus-2.91.90 )
+ playlist? ( >=dev-libs/totem-pl-parser-2.29.1:= )
+ tracker? ( >=app-misc/tracker-0.12:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-themes/hicolor-icon-theme
+ css? ( media-libs/libdvdcss:1.2 )
+ !libburn? (
+ app-cdr/cdrdao
+ app-cdr/dvd+rw-tools
+ virtual/cdrtools )
+ mp3? (
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-mad:1.0 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.3 )
+"
+# eautoreconf deps
+# app-text/yelp-tools
+# gnome-base/gnome-common
+
+PDEPEND="gnome-base/gvfs"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ --disable-caches \
+ $(use_enable !libburn cdrtools) \
+ $(use_enable !libburn cdrkit) \
+ $(use_enable !libburn cdrdao) \
+ $(use_enable !libburn growisofs) \
+ $(use_enable introspection) \
+ $(use_enable libburn libburnia) \
+ $(use_enable nautilus) \
+ $(use_enable playlist) \
+ $(use_enable tracker search) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/app-cdr/brasero/metadata.xml b/app-cdr/brasero/metadata.xml
new file mode 100644
index 000000000000..de61cac68a76
--- /dev/null
+++ b/app-cdr/brasero/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>media-optical</herd>
+ <use>
+ <flag name="packagekit">Enable support for the distro-neutral package
+ manager GUI <pkg>app-admin/packagekit</pkg></flag>
+ <flag name="nautilus">Build the <pkg>gnome-base/nautilus</pkg>
+ extension</flag>
+ <flag name="libburn">Enable <pkg>dev-libs/libburn</pkg> backend</flag>
+ <flag name="playlist">Enable support for playlists through
+ <pkg>dev-libs/totem-pl-parser</pkg></flag>
+ <flag name="tracker">Enable audio playlist search using the
+ <pkg>app-misc/tracker</pkg> indexer</flag>
+ </use>
+</pkgmetadata>