summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdck/cdck-0.7.0-r3.ebuild')
-rw-r--r--app-cdr/cdck/cdck-0.7.0-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-cdr/cdck/cdck-0.7.0-r3.ebuild b/app-cdr/cdck/cdck-0.7.0-r3.ebuild
new file mode 100644
index 000000000000..ca0805885897
--- /dev/null
+++ b/app-cdr/cdck/cdck-0.7.0-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Measure the read time per sector on CD or DVD to check the quality"
+HOMEPAGE="http://swaj.net/unix/index.html#cdck"
+SRC_URI="http://swaj.net/unix/cdck/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-wording.patch
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-cross.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}