summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdw')
-rw-r--r--app-cdr/cdw/Manifest1
-rw-r--r--app-cdr/cdw/cdw-0.8.0.ebuild37
-rw-r--r--app-cdr/cdw/files/cdw-0.8.0-uclibc.patch32
3 files changed, 0 insertions, 70 deletions
diff --git a/app-cdr/cdw/Manifest b/app-cdr/cdw/Manifest
index 71e6298b0ac4..36883d5ef749 100644
--- a/app-cdr/cdw/Manifest
+++ b/app-cdr/cdw/Manifest
@@ -1,2 +1 @@
-DIST cdw-0.8.0.tar.gz 849851 BLAKE2B 395a8cf527c676da6056dd5b887625c2d6a7ac214651351e6412e846cb435c179785c406a9e4306a72c9a7982eb8e1a0600719ca481307a8efdee5da6e626089 SHA512 67fd9e397800187baafff425fd77ae9ba679a7b396736004f305accea3c3c9ca215d70dac0410fd8ef9ed016f7ce11c3859c84bfa04e3234cee84201605175d0
DIST cdw-0.8.1.tar.gz 858791 BLAKE2B 971a5c69ef1452bb4fd02e74bb2a81492de5dc16c024d185c43bb19aa0e293b727e74f72ce73ef3aebcdb941500f95433dc6243f1171f68943b2dbe7bdc176f7 SHA512 08f6bac823f534987835f434190601d0a72df2246ff78bfe1af98fd30dda25edb8cf2e09161b3a0bc55e9efefbc453b409cc95fd3c117d447f07e49f79072e33
diff --git a/app-cdr/cdw/cdw-0.8.0.ebuild b/app-cdr/cdw/cdw-0.8.0.ebuild
deleted file mode 100644
index e716ed75db54..000000000000
--- a/app-cdr/cdw/cdw-0.8.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
-HOMEPAGE="http://cdw.sourceforge.net"
-SRC_URI="mirror://sourceforge/cdw/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-RDEPEND="
- virtual/cdrtools
- app-cdr/dvd+rw-tools
- dev-libs/libburn
- dev-libs/libcdio[-minimal]
- sys-libs/ncurses:*[unicode]
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${P}-uclibc.patch
-)
-
-src_configure() {
- econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog NEWS README THANKS cdw.conf" \
- default
-}
diff --git a/app-cdr/cdw/files/cdw-0.8.0-uclibc.patch b/app-cdr/cdw/files/cdw-0.8.0-uclibc.patch
deleted file mode 100644
index a639e21713d9..000000000000
--- a/app-cdr/cdw/files/cdw-0.8.0-uclibc.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/src/main.c
-+++ b/src/main.c
-@@ -44,7 +44,9 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#ifndef __UCLIBC__
- #include <mcheck.h>
-+#endif
- #include <signal.h> /* sig_atomic_t */
-
- #include <dirent.h> /* PATH_MAX */
---- a/src/tasks/cdw_create_image.c
-+++ b/src/tasks/cdw_create_image.c
-@@ -21,6 +21,7 @@
-
- #include <inttypes.h>
- #include <stdlib.h>
-+#include <unistd.h>
-
- #include "cdw_file_manager.h"
- #include "gettext.h"
---- a/src/utilities/cdw_utils.c
-+++ b/src/utilities/cdw_utils.c
-@@ -28,6 +28,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <unistd.h>
-
- #include "cdw_logging.h"
- #include "gettext.h"