summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu/Manifest1
-rw-r--r--app-cdr/cdemu/cdemu-3.2.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-cdr/cdemu/Manifest b/app-cdr/cdemu/Manifest
index adccfbd5986b..ae601d6567e4 100644
--- a/app-cdr/cdemu/Manifest
+++ b/app-cdr/cdemu/Manifest
@@ -1 +1,2 @@
DIST cdemu-client-3.2.0.tar.bz2 43588 BLAKE2B 0f75bed1ce2a715bb7acf227ebd3da8b80cf6418e28b0d352f294121c1f67acb8c6bab5f5dc5c768150ad46830b823d66f1940887c66225d20b41827c1377d31 SHA512 778f2ecac828ba278d0ded875c7bab2415f1c1acb62f4030eaf161376869939c48bc16a6d660326d9aacd2af745ef9dc9158f922a72aa8ccbd47f05ce41b8cd7
+DIST cdemu-client-3.2.1.tar.bz2 43584 BLAKE2B d34c09203b7b4e70161d62aee48d531b083952174fd2357bf0fc7b69a0fd59200bedb9ca87fe2d2c18c953979c84e9db3fec4d5fb500375f0bcc155dcaf5cedb SHA512 913c26754d16c339d7ddb4e00cc7d5b754ad6cc7f1a156c9448b51ed09468cf9e8a2bc74ed123a621278d2ad281e447d33ee06c3416bc1d0d2e6c2becd539154
diff --git a/app-cdr/cdemu/cdemu-3.2.1.ebuild b/app-cdr/cdemu/cdemu-3.2.1.ebuild
new file mode 100644
index 000000000000..9287c227937c
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-3.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit bash-completion-r1 cmake-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Command-line tool for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="+cdemu-daemon"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
+DEPEND="
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig"
+
+S=${WORKDIR}/cdemu-client-${PV}
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ python_fix_shebang src/cdemu
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPOST_INSTALL_HOOKS=OFF
+ -DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}