summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/k3d/k3d-5.4.9.ebuild')
-rw-r--r--app-containers/k3d/k3d-5.4.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-containers/k3d/k3d-5.4.9.ebuild b/app-containers/k3d/k3d-5.4.9.ebuild
new file mode 100644
index 000000000000..6f57b743d680
--- /dev/null
+++ b/app-containers/k3d/k3d-5.4.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="k3d creates k3s clusters in docker"
+HOMEPAGE="https://github.com/rancher/k3d"
+
+K3D_K3S_TAG=v1.24.12-k3s1
+SRC_URI="https://github.com/rancher/k3d/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0 ISC"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ GOWORK=off \
+ CGO_ENABLED=0 \
+ go build \
+ -mod=vendor \
+ -ldflags "-w -s -X github.com/k3d-io/k3d/v5/version.Version=v${PV} -X github.com/k3d-io/k3d/v5/version.K3sVersion=${K3D_K3S_TAG}" \
+ -o bin/k3d
+}
+
+src_install() {
+ dobin bin/${PN}
+ DOCS=(*.md)
+ if use doc; then
+ DOCS+=(docs)
+ fi
+ default_src_install
+}