summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/acme-sh/acme-sh-9999.ebuild')
-rw-r--r--app-crypt/acme-sh/acme-sh-9999.ebuild53
1 files changed, 30 insertions, 23 deletions
diff --git a/app-crypt/acme-sh/acme-sh-9999.ebuild b/app-crypt/acme-sh/acme-sh-9999.ebuild
index aa72ab18cd53..25fe72160c37 100644
--- a/app-crypt/acme-sh/acme-sh-9999.ebuild
+++ b/app-crypt/acme-sh/acme-sh-9999.ebuild
@@ -1,43 +1,50 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-EGIT_REPO_URI="https://github.com/Neilpang/${PN/-/.}.git"
+inherit git-r3 optfeature
-inherit git-r3
-
-DESCRIPTION="An ACME Shell script"
-HOMEPAGE="https://github.com/Neilpang/acme.sh"
-SRC_URI=""
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+EGIT_REPO_URI="https://github.com/acmesh-official/${PN/-/.}.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="net-misc/curl
- || ( dev-libs/libressl dev-libs/openssl:0 )
- || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
- || ( net-misc/socat www-servers/apache:2 www-servers/nginx )
- virtual/cron"
+IUSE="selinux"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+ selinux? ( sec-policy/selinux-certbot )
+"
src_install() {
- einstalldocs
- newdoc dnsapi/README.md README-dnsapi.md
newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
keepdir /etc/acme-sh
doenvd "${FILESDIR}"/99acme-sh
+
insinto /etc/bash/bashrc.d
doins "${FILESDIR}"/acme.sh
- exeinto /usr/share/acme.sh
- doexe acme.sh
- insinto /usr/share/acme.sh/dnsapi
- doins -r dnsapi/*.sh
- insinto /usr/share/acme.sh/deploy
- doins -r deploy/*.sh
-
dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}