summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild')
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
new file mode 100644
index 000000000000..8691a783350c
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S=${WORKDIR}/certbot-${PV}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest