summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gcr/gcr-3.36.0.ebuild')
-rw-r--r--app-crypt/gcr/gcr-3.36.0.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/app-crypt/gcr/gcr-3.36.0.ebuild b/app-crypt/gcr/gcr-3.36.0.ebuild
deleted file mode 100644
index 083725870e4d..000000000000
--- a/app-crypt/gcr/gcr-3.36.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-VALA_USE_DEPEND="vapigen"
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
-
-DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/gcr"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0/1" # subslot = suffix of libgcr-base-3 and co
-
-IUSE="gtk gtk-doc +introspection +vala"
-REQUIRED_USE="vala? ( introspection )"
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-
-DEPEND="
- >=dev-libs/glib-2.44.0:2
- >=dev-libs/libgcrypt-1.2.2:0=
- >=app-crypt/p11-kit-0.19.0
- gtk? ( >=x11-libs/gtk+-3.12:3[X,introspection?] )
- >=sys-apps/dbus-1
- introspection? ( >=dev-libs/gobject-introspection-1.58:= )
-"
-RDEPEND="${DEPEND}
- app-crypt/gnupg
-"
-BDEPEND="
- ${PYTHON_DEPS}
- gtk? ( dev-libs/libxml2:2 )
- dev-util/gdbus-codegen
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gtk-doc-1.9
- app-text/docbook-xml-dtd:4.1.2 )
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-gck-slot-test.patch
- "${FILESDIR}"/${PV}-meson-vapi-deps.patch
- "${FILESDIR}"/${PV}-meson-enum-race.patch
- "${FILESDIR}"/${PV}-avoid-gnupg-circular-dep.patch
- "${FILESDIR}"/${PV}-optional-vapi.patch
- "${FILESDIR}"/${PV}-meson-fix-gtk-doc-without-ui.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- use vala && vala_src_prepare
- xdg_src_prepare
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use introspection)
- $(meson_use gtk)
- $(meson_use gtk-doc gtk_doc)
- -Dgpg_path="${EPREFIX}"/usr/bin/gpg
- $(meson_use vala vapi)
- )
- meson_src_configure
-}
-
-src_test() {
- dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}