summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgstats/gpgstats-0.5-r2.ebuild')
-rw-r--r--app-crypt/gpgstats/gpgstats-0.5-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild b/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild
new file mode 100644
index 000000000000..860db1e0ed25
--- /dev/null
+++ b/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GPGstats calculates statistics on the keys in your key-ring"
+HOMEPAGE="http://www.vanheusden.com/gpgstats/"
+SRC_URI="http://www.vanheusden.com/gpgstats/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gpgme:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_compile() {
+ # Uses removed 'register' keyword, bug #894350
+ append-cxxflags -std=c++14
+
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" DEBUG=
+}
+
+src_install() {
+ dobin gpgstats
+ einstalldocs
+}