summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/moolticute/moolticute-9999.ebuild')
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
index 08512b4847b9..d7fa4843bf98 100644
--- a/app-crypt/moolticute/moolticute-9999.ebuild
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit qmake-utils systemd udev xdg-utils
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
inherit git-r3
else
- SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
fi
-inherit xdg-utils qmake-utils udev
-
DESCRIPTION="Mooltipass crossplatform daemon/tools"
HOMEPAGE="https://github.com/mooltipass/moolticute"
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
+IUSE="systemd"
RDEPEND="
>=dev-libs/libusb-1.0.20
@@ -29,13 +29,13 @@ RDEPEND="
dev-qt/qttest:5
dev-qt/qtwebsockets:5
dev-qt/qtwidgets:5
+ systemd? ( sys-apps/systemd )
+ !systemd? ( sys-apps/systemd-utils )
"
BDEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"
-S="${WORKDIR}/${P/_/-}"
-
src_prepare() {
default
@@ -52,7 +52,8 @@ src_configure() {
src_install() {
emake install INSTALL_ROOT="${D}"
- udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ udev_dorules "${FILESDIR}/50-mooltipass.rules"
+ systemd_dounit systemd/moolticuted.service
newinitd "${FILESDIR}/moolticuted.init" moolticuted
}
@@ -62,5 +63,6 @@ pkg_postinst() {
}
pkg_postrm() {
+ udev_reload
xdg_icon_cache_update
}