summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/nasty/nasty-0.6-r2.ebuild')
-rw-r--r--app-crypt/nasty/nasty-0.6-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/nasty/nasty-0.6-r2.ebuild b/app-crypt/nasty/nasty-0.6-r2.ebuild
new file mode 100644
index 000000000000..2596a2964bf5
--- /dev/null
+++ b/app-crypt/nasty/nasty-0.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
+HOMEPAGE="http://www.vanheusden.com/nasty/"
+SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gpgme:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG=
+}
+
+src_install() {
+ dobin nasty
+ dodoc readme.txt
+}