summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-2.1.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index f9c90c330d1c..2a06422f7d7f 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -2,3 +2,4 @@ DIST yubikey-manager-0.7.1-test-files.tar.xz 9756 BLAKE2B 5a2e2a2a58d04c8f9954c1
DIST yubikey-manager-0.7.1.tar.gz 71834 BLAKE2B 45b0366531c8a158b3d8ebcfa8b76d608c14dba02224d4e4962c3757446829e3dff5f5e0d0ceda67caab7c67ad0510e037770c58a50552c2c6971136cb75c806 SHA512 3e9105f1c033f9314b90cf209eb52f7879fa1ea69e9ae6dac8de0b24d7d2ff6e45b6dd530917535fa645d6eea461f5b4f23bb8deb103ffc27d1f3483cfa681c7
DIST yubikey-manager-1.0.0.tar.gz 90653 BLAKE2B 5d8522181ad460521995d3cae63976e06a444816a24efdc83b526d50262c902c8cc76b29d43f6f07725ee714666c853b690f1dd6fe98c9409f0cc1e722ada6f5 SHA512 9fd1926bf4e2c1278a42136a05db3e5fe0b7cb3d740f601fd0a420ab851badb61c2dd165157ac5b1f47e934f771b9d0b3cca4e07d1772d0f743556d482f77c11
DIST yubikey-manager-2.0.0.tar.gz 102078 BLAKE2B a2b8f90dabefb1014881cbe709222bf5cb48c9f409b415a8a2b27d7101c2da6189d0ebfe21a2701d10798c48c44e546659f9424ba6bf9257f7311abb0fc90b9b SHA512 42bebb88ba78bcce00a228109d0b4c815b3242ddbe43fd26c1209ba8666eb033ab77d5acd39a157e8310ce327de8d38bf88cfa0ffaed6273236b220c39e72e3b
+DIST yubikey-manager-2.1.0.tar.gz 132797 BLAKE2B 39a170901dd10443f7cd639d1f525b12074ed042f606c083fe5b1bf04f463f608c4968c1e7f06dd057ff519a2a4bf712d36643e7db164ef92a3152ea5fb7ae15 SHA512 05cc1a106ffd2b40bc0a1286fa2f9c19f022bc7db04b85c9aaab3c67cad92a0c8ee4ba70f9b62ffa7f02ce67525a7d5f03bf9160b9bbe38909232cf75eb39373
diff --git a/app-crypt/yubikey-manager/yubikey-manager-2.1.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-2.1.0.ebuild
new file mode 100644
index 000000000000..30b06435964d
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-2.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ dev-python/fido2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-auth/ykpers-1.19.0
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+ readme.gentoo_create_doc
+
+ doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}