summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/aspell-be/aspell-be-0.01-r2.ebuild')
-rw-r--r--app-dicts/aspell-be/aspell-be-0.01-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild b/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild
new file mode 100644
index 000000000000..c0ce4d1b7155
--- /dev/null
+++ b/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ASPELL_LANG="Belarusian"
+ASPELL_VERSION=5
+MY_P="${PN/aspell/aspell"${ASPELL_VERSION}"}-${PV}"
+
+inherit aspell-dict-r1
+
+SRC_URI="mirror://gnu/${PN%-*}/dict/${PN/aspell-/}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="classic"
+
+src_prepare() {
+ ! use classic && local PATCHES=( "${FILESDIR}"/aspell5-be-${PV}-official.patch )
+
+ default
+}