summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild')
-rw-r--r--app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
index cc87a5b9fd0b..0ae6c89946c7 100644
--- a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
+++ b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit python-any-r1 python-utils-r1 vcs-clean
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+inherit python-any-r1 vcs-clean
COMMIT="9d711f40638202b02f2154d7f05ea35088ff9388"
@@ -15,22 +15,26 @@ S="${WORKDIR}/MathJax-docs-${COMMIT}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
BDEPEND="
$(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
')
"
-DOCS=(
- README.md
-)
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]"
+}
+
+DOCS=( README.md )
src_prepare() {
default
egit_clean
+ sed -e 's/add_stylesheet/add_css_file/' -i conf.py || die
}
src_compile() {