summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghex/ghex-9999.ebuild')
-rw-r--r--app-editors/ghex/ghex-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index b9a8b8490096..6bc800a0f081 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
SRC_URI=""
else
- KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2+ FDL-1.1+"
@@ -22,8 +22,9 @@ RESTRICT="!test? ( test )"
SLOT="4"
RDEPEND="
- >=dev-libs/glib-2.66.0:2
- >=gui-libs/gtk-4.0.0:4
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ gui-libs/libadwaita:1
dev-libs/gobject-introspection
!app-editors/ghex:2
"
@@ -43,8 +44,13 @@ BDEPEND="
src_configure() {
local emesonargs=(
-Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
-Dintrospection=enabled
$(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
)
meson_src_configure
}