summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghex/ghex-9999.ebuild')
-rw-r--r--app-editors/ghex/ghex-9999.ebuild40
1 files changed, 29 insertions, 11 deletions
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index 02e8fb9d1908..6bc800a0f081 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,30 +13,48 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
SRC_URI=""
else
- MY_PV="4.alpha.1"
- SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
SLOT="4"
RDEPEND="
- >=dev-libs/atk-1.0.0
- >=dev-libs/glib-2.31.10:2
- >=x11-libs/gtk+-3.3.8:3
- gui-libs/gtk:4
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxml2:2
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update