summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hyx/hyx-2021.06.09.ebuild')
-rw-r--r--app-editors/hyx/hyx-2021.06.09.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/hyx/hyx-2021.06.09.ebuild b/app-editors/hyx/hyx-2021.06.09.ebuild
new file mode 100644
index 000000000000..4877bc384b3b
--- /dev/null
+++ b/app-editors/hyx/hyx-2021.06.09.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalistic console hex editor with vim-like controls"
+HOMEPAGE="https://yx7.cc/code/"
+SRC_URI="https://yx7.cc/code/hyx/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=(
+ # Avoid complaining about not respecting LDFLAGS
+ "${FILESDIR}/${PN}-ldflags.patch"
+)
+
+src_compile() {
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin hyx
+}