summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nano/nano-9999.ebuild')
-rw-r--r--app-editors/nano/nano-9999.ebuild52
1 files changed, 35 insertions, 17 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index ad20434b2ed1..80da99c51009 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -1,33 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
+
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
else
MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Guide"
-LICENSE="GPL-3"
+LICENSE="GPL-3+ LGPL-2.1+ || ( GPL-3+ FDL-1.2+ )"
SLOT="0"
-IUSE="debug justify magic minimal ncurses nls +spell +split-usr static unicode"
+IUSE="debug justify magic minimal ncurses nls +spell static unicode"
LIB_DEPEND="
>=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
sys-libs/ncurses:=[static-libs(+)]
magic? ( sys-apps/file[static-libs(+)] )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
BDEPEND="
nls? ( sys-devel/gettext )
virtual/pkgconfig
@@ -39,14 +43,16 @@ REQUIRED_USE="
src_prepare() {
default
- if [[ ${PV} == "9999" ]] ; then
+
+ if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
}
src_configure() {
use static && append-ldflags -static
- local myconf=(
+
+ local myconfargs=(
--bindir="${EPREFIX}"/bin
--htmldir=/trash
$(use_enable !minimal color)
@@ -60,12 +66,14 @@ src_configure() {
$(use_enable unicode utf8)
$(use_enable minimal tiny)
)
- econf "${myconf[@]}"
+
+ econf "${myconfargs[@]}"
}
src_install() {
default
- # don't use "${ED}" here or things break (#654534)
+
+ # Don't use "${ED}" here or things break (#654534)
rm -r "${D}"/trash || die
dodoc doc/sample.nanorc
@@ -73,6 +81,7 @@ src_install() {
dodoc doc/faq.html
insinto /etc
newins doc/sample.nanorc nanorc
+
if ! use minimal ; then
# Enable colorization by default.
sed -i \
@@ -86,8 +95,17 @@ src_install() {
rmdir "${ED}"${rcdir}/extra || die
insinto "${rcdir}"
- doins "${FILESDIR}/gentoo.nanorc"
+ newins "${FILESDIR}/gentoo.nanorc-r1" gentoo.nanorc
fi
+}
- use split-usr && dosym ../../bin/nano /usr/bin/nano
+pkg_postrm() {
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
}