summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild43
1 files changed, 25 insertions, 18 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 214372f2d90a..38c1165fb129 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,17 +1,14 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# Please don't add pypy support before testing if it's actually supported. The
-# old compat matrix is no longer accessible as of 2021-02-13 but stated back
-# in 2020-07-05 that PyQt5 was explicitly not supported.
-PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
-inherit distutils-r1 optfeature qmake-utils virtualx xdg
-
-MY_PN="ReText"
-MY_P="${MY_PN}-${PV/_/~}"
+inherit desktop distutils-r1 optfeature qmake-utils virtualx xdg
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
@@ -20,10 +17,8 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/retext-project/retext.git"
else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
- KEYWORDS="~amd64 ~riscv ~x86"
+ inherit pypi
+ KEYWORDS="~amd64"
fi
LICENSE="GPL-2+"
@@ -37,12 +32,12 @@ RDEPEND="
>=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
- dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-qt/linguist-tools
- test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )
+ test? ( dev-python/PyQt6[testlib,${PYTHON_USEDEP}] )
"
distutils_enable_tests unittest
@@ -57,18 +52,30 @@ src_test() {
}
python_test() {
- eunittest || die
+ virtx eunittest
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon data/retext-kde5.png retext.png
+
+ # Fixme: The application actually provides a desktop file which theoretically
+ # could be used, so far though I could not make it install properly.
+ make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
}
pkg_postinst() {
xdg_pkg_postinst
optfeature "dictionary support" dev-python/pyenchant
- # See https://bugs.gentoo.org/772197.
- optfeature "rendering with webengine" dev-python/PyQtWebEngine
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"
einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}