summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/retext/retext-9999.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 68382ad9fb77..b69ab5bac2a4 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
PLOCALES="ca cs cy da de es et eu fr hu it ja pl pt pt_BR ru sk sr sr@latin uk zh_TW"
-inherit distutils-r1 virtualx git-r3 l10n
+inherit distutils-r1 virtualx l10n xdg-utils
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_P}
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="+spell"
RDEPEND="
@@ -28,7 +35,7 @@ RDEPEND="
>=dev-python/markups-2.0[${PYTHON_USEDEP}]
>=dev-python/chardet-2.3[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,network,printsupport,webkit,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,printsupport,webengine,widgets,${PYTHON_USEDEP}]
spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
"
@@ -43,10 +50,13 @@ python_test() {
python_install_all() {
distutils-r1_python_install_all
- newicon {icons/,}${PN}.png
- newicon {icons/,}${PN}.svg
-
l10n_for_each_disabled_locale_do remove_locale
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
- make_desktop_entry ${PN} "${MY_PN} Editor" ${PN} "Development;Utility;TextEditor"
+pkg_postrm() {
+ xdg_desktop_database_update
}