summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/metadata.xml11
-rw-r--r--app-editors/okteta/okteta-17.12.3.ebuild63
3 files changed, 75 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
new file mode 100644
index 000000000000..3bc9acc020a5
--- /dev/null
+++ b/app-editors/okteta/Manifest
@@ -0,0 +1 @@
+DIST okteta-17.12.3.tar.xz 962772 BLAKE2B 4a347db4db1d248ccb73e2ab77d4b10449ccea2e1e23ae7770a338f1c96f3990de4a3362b566abde29d47ef4b1084614e219ea646e4b0704ecac048a4559d921 SHA512 d89bcd46001336d912f2d3f08247cdb13a02688316f078455e851feae03b638688683df2779c19089481b69baa2a582fd063d3180ebe66962ab249fc39c3850d
diff --git a/app-editors/okteta/metadata.xml b/app-editors/okteta/metadata.xml
new file mode 100644
index 000000000000..a50ada50ef0e
--- /dev/null
+++ b/app-editors/okteta/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="designer">Build plugins for <pkg>dev-qt/designer</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-editors/okteta/okteta-17.12.3.ebuild b/app-editors/okteta/okteta-17.12.3.ebuild
new file mode 100644
index 000000000000..fa883ad1b7c3
--- /dev/null
+++ b/app-editors/okteta/okteta-17.12.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+SRC_URI="mirror://kde/stable/applications/${PV}/${P}.tar.xz"
+KEYWORDS="amd64 x86"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ $(cmake-utils_use_find_package designer Qt5Designer)
+ $(cmake-utils_use_find_package designer Qt5UiPlugin)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}