summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/amyedit/amyedit-1.0-r2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-editors/amyedit/amyedit-1.0-r2.ebuild b/app-editors/amyedit/amyedit-1.0-r2.ebuild
index 4e47fcfa4102..86575b0e01af 100644
--- a/app-editors/amyedit/amyedit-1.0-r2.ebuild
+++ b/app-editors/amyedit/amyedit-1.0-r2.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
-
-inherit eutils autotools
+EAPI=5
+inherit autotools eutils flag-o-matic
DESCRIPTION=" AmyEdit is a LaTeX editor"
HOMEPAGE="http://amyedit.sf.net"
@@ -29,10 +28,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-gcc45.patch"
epatch "${FILESDIR}/${P}-sourceviewmm2.patch"
rm -rf "${S}/src/gtksourceviewmm" || die
+ append-cxxflags -std=c++11
+ mv configure.in configure.ac || die
eautoreconf
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README TODO || die
-}