summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/buffer-extension/buffer-extension-0.1-r1.ebuild')
-rw-r--r--app-emacs/buffer-extension/buffer-extension-0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/buffer-extension/buffer-extension-0.1-r1.ebuild b/app-emacs/buffer-extension/buffer-extension-0.1-r1.ebuild
new file mode 100644
index 000000000000..5a56d9820ab3
--- /dev/null
+++ b/app-emacs/buffer-extension/buffer-extension-0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Some enhanced functions for buffer manipulate"
+HOMEPAGE="https://www.emacswiki.org/emacs/buffer-extension.el"
+# taken from https://www.emacswiki.org/emacs/download/buffer-extension.el
+SRC_URI="https://github.com/gavv/distfiles/raw/master/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/basic-toolkit"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}