summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cask-mode/cask-mode-0.1.ebuild')
-rw-r--r--app-emacs/cask-mode/cask-mode-0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/cask-mode/cask-mode-0.1.ebuild b/app-emacs/cask-mode/cask-mode-0.1.ebuild
new file mode 100644
index 000000000000..f86dea2e9c3a
--- /dev/null
+++ b/app-emacs/cask-mode/cask-mode-0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing Cask files for Emacs"
+HOMEPAGE="https://github.com/Wilfred/cask-mode/"
+SRC_URI="https://github.com/Wilfred/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/assess
+ app-emacs/ert-runner
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ # Silence a broken test
+ sed "s|ert-deftest cask-mode-highlight-comment|lambda|" \
+ -i test/${PN}-test.el || die
+}
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}