summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/d-mode/d-mode-2.0.12.ebuild')
-rw-r--r--app-emacs/d-mode/d-mode-2.0.12.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/d-mode/d-mode-2.0.12.ebuild b/app-emacs/d-mode/d-mode-2.0.12.ebuild
new file mode 100644
index 000000000000..ae388dd29811
--- /dev/null
+++ b/app-emacs/d-mode/d-mode-2.0.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing D code"
+HOMEPAGE="https://github.com/Emacs-D-Mode-Maintainers/Emacs-D-Mode
+ https://www.emacswiki.org/emacs/DMode"
+SRC_URI="https://github.com/Emacs-D-Mode-Maintainers/Emacs-D-Mode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Emacs-D-Mode-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -l ${PN}.el -l ${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}