summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emhacks/emhacks-20070920.ebuild')
-rw-r--r--app-emacs/emhacks/emhacks-20070920.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/emhacks/emhacks-20070920.ebuild b/app-emacs/emhacks/emhacks-20070920.ebuild
new file mode 100644
index 000000000000..f072a1c1b122
--- /dev/null
+++ b/app-emacs/emhacks/emhacks-20070920.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Useful Emacs Lisp libraries, including gdiff, jjar, jmaker, swbuff, and tabbar"
+HOMEPAGE="http://emhacks.sourceforge.net/"
+# CVS snapshot
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jde"
+
+DEPEND="jde? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # remove files included in Emacs>=22 or not useful on GNU/Linux
+ rm -r findstr* overlay-fix* recentf* ruler-mode* tree-widget* || die
+ # this requires jde and cedet, not everyone may want it
+ use jde || rm jsee.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}"
+ use jde || sed -i -e '/;; jsee/,$d' "${T}/${SITEFILE}"
+ elisp-site-file-install "${T}/${SITEFILE}"
+
+ dodoc Changelog
+}