summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/exheres-mode/exheres-mode-1.10.ebuild')
-rw-r--r--app-emacs/exheres-mode/exheres-mode-1.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/exheres-mode/exheres-mode-1.10.ebuild b/app-emacs/exheres-mode/exheres-mode-1.10.ebuild
new file mode 100644
index 000000000000..d492da0eeb83
--- /dev/null
+++ b/app-emacs/exheres-mode/exheres-mode-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing files in exheres format"
+HOMEPAGE="https://www.exherbolinux.org/
+ https://gitlab.exherbolinux.org/exherbo-misc/exheres-mode/"
+SRC_URI="https://dev.exherbo.org/distfiles/${PN}/${P}.tar.xz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}