summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/parsebib/parsebib-4.3.ebuild')
-rw-r--r--app-emacs/parsebib/parsebib-4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/parsebib/parsebib-4.3.ebuild b/app-emacs/parsebib/parsebib-4.3.ebuild
new file mode 100644
index 000000000000..86b48a11e4ab
--- /dev/null
+++ b/app-emacs/parsebib/parsebib-4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp library for reading .bib files"
+HOMEPAGE="https://github.com/joostkremers/parsebib/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}