summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pov-mode/pov-mode-3.2.ebuild')
-rw-r--r--app-emacs/pov-mode/pov-mode-3.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/pov-mode/pov-mode-3.2.ebuild b/app-emacs/pov-mode/pov-mode-3.2.ebuild
new file mode 100644
index 000000000000..f9ee93a5b39f
--- /dev/null
+++ b/app-emacs/pov-mode/pov-mode-3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs mode for povray"
+HOMEPAGE="https://gitorious.org/pov-mode/pov-mode/trees/master"
+#SRC_URI="http://tromey.com/elpa/${P}.tar"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="info/${PN}.texi"
+DOCS="README"
+
+src_prepare() {
+ rm -f *.info || die # ensure we build them from source
+}
+
+src_install() {
+ elisp_src_install
+ insinto ${SITEETC}/${PN}
+ doins *.xpm
+ doins -r InsertMenu/
+}