summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pov-mode')
-rw-r--r--app-emacs/pov-mode/Manifest2
-rw-r--r--app-emacs/pov-mode/files/50pov-mode-gentoo.el9
-rw-r--r--app-emacs/pov-mode/metadata.xml8
-rw-r--r--app-emacs/pov-mode/pov-mode-3.2.ebuild32
-rw-r--r--app-emacs/pov-mode/pov-mode-3.3.ebuild29
5 files changed, 80 insertions, 0 deletions
diff --git a/app-emacs/pov-mode/Manifest b/app-emacs/pov-mode/Manifest
new file mode 100644
index 000000000000..1a8259a74138
--- /dev/null
+++ b/app-emacs/pov-mode/Manifest
@@ -0,0 +1,2 @@
+DIST pov-mode-3.2.tar.gz 65120 SHA256 b98f6c1a1778d4d7f9ecbccdf20fa233ccf9f502306a43fd2f52bf8ef3d019e6 SHA512 da8cc0172fb47fe201457609bff36ff9c9b3b9930c23ee02eb2d302c44275e8402916f3a6424013573a190d0ebc0e652f88a6f47283ba0e5953009ececf8ce31 WHIRLPOOL f3a70ed0aa0d12cc161dc003a7b208f626b5b7f7cbc07b01e211a94e7f9e8cbdfcdf49ada05625fc3a5d8602c832a53b8c1a5a5197d1e22c391358adc4f980a3
+DIST pov-mode-3.3.tar.gz 65929 SHA256 ff766da83af91d17a2ab4103ded50fa2025a6e79dd97114c9cc96cd0d34587d8 SHA512 e705f25f1eb719152dbf5ec17c833f67b4c7be5b1ff9ddab94f67830d9d2caddabc47bcc6ce4864521eedd2728f4b59a6d2c0ddaba83f0b194bb0834d86e9396 WHIRLPOOL 51d9661dc7cfbd63da87eafc4951c9d9321f77ffd933f22f51d83a37280d374014b90e35630207f1a395bd83f28802f186197eb5a89a9ea45d9a1e750a76e395
diff --git a/app-emacs/pov-mode/files/50pov-mode-gentoo.el b/app-emacs/pov-mode/files/50pov-mode-gentoo.el
new file mode 100644
index 000000000000..0489820ec5f6
--- /dev/null
+++ b/app-emacs/pov-mode/files/50pov-mode-gentoo.el
@@ -0,0 +1,9 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pov-mode "pov-mode" "PoVray scene file mode" t)
+(add-to-list 'auto-mode-alist '("\\.pov\\'" . pov-mode))
+;;(add-to-list 'auto-mode-alist '("\\.inc\\'" . pov-mode))
+
+;; Override customization variables setting various directories.
+(setq pov-include-dir "/usr/share/povray/include")
+(setq pov-insertmenu-location "@SITEETC@/InsertMenu")
+(setq pov-icons-location "@SITEETC@/")
diff --git a/app-emacs/pov-mode/metadata.xml b/app-emacs/pov-mode/metadata.xml
new file mode 100644
index 000000000000..f09c9defae46
--- /dev/null
+++ b/app-emacs/pov-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="gitorious">pov-mode</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/pov-mode/pov-mode-3.2.ebuild b/app-emacs/pov-mode/pov-mode-3.2.ebuild
new file mode 100644
index 000000000000..f9ee93a5b39f
--- /dev/null
+++ b/app-emacs/pov-mode/pov-mode-3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs mode for povray"
+HOMEPAGE="https://gitorious.org/pov-mode/pov-mode/trees/master"
+#SRC_URI="http://tromey.com/elpa/${P}.tar"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="info/${PN}.texi"
+DOCS="README"
+
+src_prepare() {
+ rm -f *.info || die # ensure we build them from source
+}
+
+src_install() {
+ elisp_src_install
+ insinto ${SITEETC}/${PN}
+ doins *.xpm
+ doins -r InsertMenu/
+}
diff --git a/app-emacs/pov-mode/pov-mode-3.3.ebuild b/app-emacs/pov-mode/pov-mode-3.3.ebuild
new file mode 100644
index 000000000000..29c3440d9eba
--- /dev/null
+++ b/app-emacs/pov-mode/pov-mode-3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs mode for povray"
+HOMEPAGE="http://gitorious.org/pov-mode/"
+SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${PN}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="${PN}-pkg.el ${PN}.info"
+ELISP_TEXINFO="info/${PN}.texi"
+DOCS="README"
+
+src_install() {
+ elisp_src_install
+ insinto ${SITEETC}/${PN}
+ doins *.xpm
+ doins -r InsertMenu/
+}