summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/Manifest3
-rw-r--r--app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el2
-rw-r--r--app-emacs/sml-mode/files/50sml-mode-gentoo.el1
-rw-r--r--app-emacs/sml-mode/metadata.xml5
-rw-r--r--app-emacs/sml-mode/sml-mode-5.0.ebuild26
-rw-r--r--app-emacs/sml-mode/sml-mode-6.1-r1.ebuild25
-rw-r--r--app-emacs/sml-mode/sml-mode-6.4.ebuild24
7 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/Manifest b/app-emacs/sml-mode/Manifest
new file mode 100644
index 000000000000..fe102abdf116
--- /dev/null
+++ b/app-emacs/sml-mode/Manifest
@@ -0,0 +1,3 @@
+DIST sml-mode-5.0.tar.gz 73324 SHA256 4aecb081ef839e94345aec31840a9c3805771c857298e87d8c153ec52ddb9fb5 SHA512 250dd6a25e8e456fc0c002e77b2bd27a5de6f13d7c6f530a71213853fcca0bda340474f68411c7bba237282d47d1e91334e05b521ee4990f0bda1daf8966b2ee WHIRLPOOL 8f7c004f82a663c97a647461d0dd2842e739f54d0fceab5fcfa3295eb1749443d18f585edfd07435a702deaa4094bca38531404abc5c186d16fb76874621ef69
+DIST sml-mode-6.1.el.xz 19012 SHA256 6a9cf07a199bc01d1f4163ada0d44b0669cf1ef4e2fa5bf6372d98fc84c634a6 SHA512 fd7566cc345b7df262f30648fcd7c8196b1615b9a9c4bc290db9125cedccda1340c07214eb9d9f17151c1c161ac72942e9ba35935133e8a6a857502ae89cff09 WHIRLPOOL bb2e9276900c36d2de1506710ff33cb4aceee641cb0ea23436f55487390fc9e4be0db053d85d7b693afbf72ba70579b2590c8fef0e738a47026b8f53b70a10b0
+DIST sml-mode-6.4.el.xz 20512 SHA256 ce524bd955fe3bd7e548e00ea4f568fd2b045f635268a086167b86a5d3760efe SHA512 238c69cf34bdd9b825fdc00e65741a458e64bf4bf38ed96ba0518154dd92f25877d56d09f4c13271577ea8641ca828023db950db07a42fe1a02659527b65cb5b WHIRLPOOL 16c534d6aa9e354804ab74717bdd9872dea8d67645ec541ba230b4cc7cea0a79c376ef9067ad4e9d6b1e0aaa56d47cc47329081293c4f2f519bb4e2c6f2d9f2b
diff --git a/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
new file mode 100644
index 000000000000..feb0eb3a9551
--- /dev/null
+++ b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "sml-mode-autoloads" nil t)
diff --git a/app-emacs/sml-mode/files/50sml-mode-gentoo.el b/app-emacs/sml-mode/files/50sml-mode-gentoo.el
new file mode 100644
index 000000000000..bae8d0c06942
--- /dev/null
+++ b/app-emacs/sml-mode/files/50sml-mode-gentoo.el
@@ -0,0 +1 @@
+(load "@SITELISP@/sml-mode-startup" nil t)
diff --git a/app-emacs/sml-mode/metadata.xml b/app-emacs/sml-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/sml-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/sml-mode/sml-mode-5.0.ebuild b/app-emacs/sml-mode/sml-mode-5.0.ebuild
new file mode 100644
index 000000000000..76967bb6b4b1
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+SRC_URI="http://www.iro.umontreal.ca/~monnier/elisp/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="${PN}.texi"
+DOCS="BUGS ChangeLog NEWS README TODO"
+
+src_compile() {
+ default
+}
diff --git a/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
new file mode 100644
index 000000000000..e4db1c4174d1
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://bzr.sv.gnu.org/r/emacs/elpa
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+DEPEND="app-arch/xz-utils"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+}
diff --git a/app-emacs/sml-mode/sml-mode-6.4.ebuild b/app-emacs/sml-mode/sml-mode-6.4.ebuild
new file mode 100644
index 000000000000..fa0bec00396e
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://elpa.gnu.org/packages/${P}.el
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}