summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/twittering-mode/twittering-mode-3.0.0-r1.ebuild')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-3.0.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-3.0.0-r1.ebuild b/app-emacs/twittering-mode/twittering-mode-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..ed246a376260
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-3.0.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
+ inherit git-r3
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
+}
+
+src_install() {
+ elisp-install ${PN} twittering-mode.el *.elc
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
+}