summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/xclip')
-rw-r--r--app-emacs/xclip/Manifest2
-rw-r--r--app-emacs/xclip/files/50xclip-gentoo.el3
-rw-r--r--app-emacs/xclip/metadata.xml5
-rw-r--r--app-emacs/xclip/xclip-1.0.ebuild26
-rw-r--r--app-emacs/xclip/xclip-1.3.ebuild20
5 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/xclip/Manifest b/app-emacs/xclip/Manifest
new file mode 100644
index 000000000000..adf6e4e4f7d3
--- /dev/null
+++ b/app-emacs/xclip/Manifest
@@ -0,0 +1,2 @@
+DIST xclip-1.0.el.xz 1560 SHA256 ea9bd42646872b6b0c67d352d9b875e23cc6604c56ec131a901a615c0f50184d SHA512 7d18992927f9b0c54db289ac2bdb1612fb6a7fc59b6ec22e83ef62c9e23c963adbffb9da5b8dbeccd9465063ed39884f14ee4b7ad5f0317a7e12ab041ed7d723 WHIRLPOOL 55dde6bd7e65196cc9c226853f5bb74a774da4837e9448341f98512b3f7123f6013bbaa80bbca9a9c3dfc4936c18cadb3c8ef3cac44705f867997209fcdb5e5d
+DIST xclip-1.3.el.xz 2164 SHA256 10ecb4d2f11c65707be3a1646f07b51d56a6670e30c676a94c03664b01930ab5 SHA512 5b51703a365fa3991a97c06734b6baf6473ba672ab2ed572db45330fc6b761258403191079725f8c3e8d72919355a2cadf0c04e31396805718de30474ac08520 WHIRLPOOL b24f22cd7c194897b52df134cfa9d55a40bf158de901ef65c10df0e428202739fcac599bfb476beadfebf88cf80d2ab06c21333a7f791ac7d1fe3890afa17941
diff --git a/app-emacs/xclip/files/50xclip-gentoo.el b/app-emacs/xclip/files/50xclip-gentoo.el
new file mode 100644
index 000000000000..32fe005725b4
--- /dev/null
+++ b/app-emacs/xclip/files/50xclip-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'xclip-mode "xclip"
+ "Minor mode to use the `xclip' program to copy&paste." t)
diff --git a/app-emacs/xclip/metadata.xml b/app-emacs/xclip/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/xclip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/xclip/xclip-1.0.ebuild b/app-emacs/xclip/xclip-1.0.ebuild
new file mode 100644
index 000000000000..3151a102355b
--- /dev/null
+++ b/app-emacs/xclip/xclip-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs Interface to XClip"
+HOMEPAGE="http://elpa.gnu.org/packages/"
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="x11-misc/xclip"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "To enable xclip-mode, add (xclip-mode 1) to your ~/.emacs file."
+}
diff --git a/app-emacs/xclip/xclip-1.3.ebuild b/app-emacs/xclip/xclip-1.3.ebuild
new file mode 100644
index 000000000000..4b7f3c91acf4
--- /dev/null
+++ b/app-emacs/xclip/xclip-1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Emacs Interface to XClip"
+HOMEPAGE="http://elpa.gnu.org/packages/xclip.html"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-misc/xclip"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="To enable xclip-mode, add (xclip-mode 1) to your ~/.emacs file."