summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libspectrum')
-rw-r--r--app-emulation/libspectrum/Manifest2
-rw-r--r--app-emulation/libspectrum/libspectrum-1.0.0.ebuild42
-rw-r--r--app-emulation/libspectrum/libspectrum-1.1.1.ebuild42
-rw-r--r--app-emulation/libspectrum/metadata.xml28
4 files changed, 114 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/Manifest b/app-emulation/libspectrum/Manifest
new file mode 100644
index 000000000000..44fd1be27e99
--- /dev/null
+++ b/app-emulation/libspectrum/Manifest
@@ -0,0 +1,2 @@
+DIST libspectrum-1.0.0.tar.gz 462552 SHA256 cdf8f5006676c0f68939e331eeadeda5d608d777f1234b080b97f677f1dd287c SHA512 1ed3e36e9d62d69b470e959509d2a56e5a3608a9ea9f3f6f0ddd78e4f5f4a75da957e4120a0ffdf6366c3e90e148de9d83954fc711414389687e55bbc91f1bc8 WHIRLPOOL bf245f20181c82bae9e985e230729c3f341134f84239d82133231b2de5d8fe61533a1e11a9004b6d5a0971bdd97622ba453912522c66292b82715a5a937d351b
+DIST libspectrum-1.1.1.tar.gz 502942 SHA256 178d3607af2109b6b8dafac4f91912745b9f3c087319945c3a886bb7fe7989d5 SHA512 61197c8d1d6b4b595b55cf7e8f8c43423935291a9fbc688f1bb06d4c3ef53dbcf391a96f0528443518c2ca2d6fe187ee56d5ed915702f13a16ad44aa16037f49 WHIRLPOOL c89c7c3183f9d960dcedf789c763687e66cdaea1b2c41fdd41c1f1b0484cc9039790415bf8f231ff2bea0914fe2ababfd6d174338141bee13859521bf73caa92
diff --git a/app-emulation/libspectrum/libspectrum-1.0.0.ebuild b/app-emulation/libspectrum/libspectrum-1.0.0.ebuild
new file mode 100644
index 000000000000..a0455acbd775
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="audiofile bzip2 gcrypt zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( >=app-arch/bzip2-1.0 )
+ >=dev-libs/glib-2
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-glib \
+ $(use_with zlib zlib) \
+ $(use_with bzip2 bzip2) \
+ $(use_with audiofile libaudiofile) \
+ $(use_with gcrypt libgcrypt) \
+ || die "econf failed!"
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Make install failed"
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+ doman doc/libspectrum.3
+}
diff --git a/app-emulation/libspectrum/libspectrum-1.1.1.ebuild b/app-emulation/libspectrum/libspectrum-1.1.1.ebuild
new file mode 100644
index 000000000000..509cc383833a
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="audiofile bzip2 gcrypt zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( >=app-arch/bzip2-1.0 )
+ >=dev-libs/glib-2
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-glib \
+ $(use_with zlib zlib) \
+ $(use_with bzip2 bzip2) \
+ $(use_with audiofile libaudiofile) \
+ $(use_with gcrypt libgcrypt) \
+ || die "econf failed!"
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Make install failed"
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+ doman doc/libspectrum.3
+}
diff --git a/app-emulation/libspectrum/metadata.xml b/app-emulation/libspectrum/metadata.xml
new file mode 100644
index 000000000000..1995e4955b86
--- /dev/null
+++ b/app-emulation/libspectrum/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ <description>Proxy Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>jmfo1982@yahoo.es</email>
+ <description>Proxied Maintainer. Please CC on bugs.</description>
+ <name>José Manuel Ferrer Ortiz</name>
+ </maintainer>
+ <longdescription>
+libspectrum is a library designed to make the input and output of some ZX
+Spectrum emulator files slightly easier. It is intended to be usable on Unix
+variants, Win32 and Mac OS X. Currently, it is mainly (only?) used by Fuse,
+but other Spectrum emulator and utility authors are encouraged to use it.
+</longdescription>
+ <use>
+ <flag name="gcrypt">Use <pkg>dev-libs/libgcrypt</pkg> for low-level crypto of some
+ features, including logfiles.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">fuse-emulator</remote-id>
+ </upstream>
+</pkgmetadata>