summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild72
1 files changed, 51 insertions, 21 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 0db98eda49d5..29549b6f4ecb 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -1,48 +1,71 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# python is needed by xcb-0.8.2 until update to >=0.10
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="xml(+)"
-inherit cargo desktop flag-o-matic git-r3 python-any-r1 xdg
+inherit cargo desktop git-r3 optfeature xdg
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
EGIT_REPO_URI="https://github.com/ruffle-rs/ruffle.git"
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 ZLIB curl unicode"
+LICENSE="|| ( Apache-2.0 MIT )"
+LICENSE+="
+ Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC UbuntuFontLicense-1.0 MIT
+ MPL-2.0 OFL-1.1 openssl Unicode-DFS-2016 ZLIB
+" # crates
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
- dev-libs/glib:2
- dev-libs/openssl:=
media-libs/alsa-lib
- sys-libs/zlib:=
- x11-libs/gtk+:3
- x11-libs/libxcb:="
-DEPEND="${RDEPEND}"
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXrender
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
BDEPEND="
- ${PYTHON_DEPS}
virtual/jre:*
virtual/pkgconfig
- >=virtual/rust-1.62"
+ >=virtual/rust-1.76
+"
-QA_FLAGS_IGNORED="
- usr/bin/${PN}
- usr/bin/${PN}_exporter
- usr/bin/${PN}_scanner"
+QA_FLAGS_IGNORED="usr/bin/${PN}.*"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_p20231216-skip-render-tests.patch
+)
src_unpack() {
git-r3_src_unpack
cargo_live_src_unpack
}
-src_compile() {
- filter-lto # undefined references with ring crate and more
+src_configure() {
+ local workspaces=(
+ ruffle_{desktop,scanner}
+ exporter
+ $(usev test tests)
+ )
+
+ cargo_src_configure "${workspaces[@]/#/--package=}"
+}
+
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
- cargo_src_compile --bins # note: configure --bins would skip tests
+ cargo_src_test -- "${skip[@]}"
}
src_install() {
@@ -52,9 +75,16 @@ src_install() {
make_desktop_entry ${PN} ${PN^} ${PN} "AudioVideo;Player;Emulator;" \
"MimeType=application/x-shockwave-flash;application/vnd.adobe.flash.movie;"
+ # TODO: swap with /gentoo after https://github.com/gentoo/gentoo/pull/29510
cd target/$(usex debug{,} release) || die
newbin ${PN}_desktop ${PN}
newbin exporter ${PN}_exporter
dobin ${PN}_scanner
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "the in-application file picker" sys-apps/xdg-desktop-portal
+}