summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild118
1 files changed, 82 insertions, 36 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 664241e57d2e..12ec38649be1 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+MULTILIB_ABIS="amd64 x86" # allow usage on /no-multilib/
MULTILIB_COMPAT=( abi_x86_{32,64} )
inherit flag-o-matic meson-multilib toolchain-funcs
@@ -12,20 +13,28 @@ if [[ ${PV} == 9999 ]]; then
EGIT_SUBMODULES=(
# uses hacks / recent features and easily breaks, keep bundled headers
# (also cross-compiled and -I/usr/include is troublesome)
- subprojects/{SPIRV,Vulkan}-Headers
+ khronos/{SPIRV,Vulkan}-Headers
subprojects/dxil-spirv
subprojects/dxil-spirv/third_party/spirv-headers # skip cross/tools
)
else
- VKD3D_HASH=3e5aab6fb3e18f81a71b339be4cb5cdf55140980 # match tag on bumps
- DXIL_HASH=b537bbb91bccdbc695cb7e5211d608f8d1c205bd
- SPIRV_HASH=ae217c17809fadb232ec94b29304b4afcd417bb4
- VULKAN_HASH=83e1a9ed8ce289cebb1c02c8167d663dc1befb24
+ HASH_VKD3D= # match tag on bumps
+ HASH_DXIL=
+ HASH_SPIRV=
+ HASH_SPIRV_DXIL=
+ HASH_VULKAN=
SRC_URI="
- https://github.com/HansKristian-Work/vkd3d-proton/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/HansKristian-Work/dxil-spirv/archive/${DXIL_HASH}.tar.gz -> ${P}-dxil-spirv.tar.gz
- https://github.com/KhronosGroup/SPIRV-Headers/archive/${SPIRV_HASH}.tar.gz -> ${P}-vulkan-headers.tar.gz
- https://github.com/KhronosGroup/Vulkan-Headers/archive/${VULKAN_HASH}.tar.gz -> ${P}-spirv-headers.tar.gz"
+ https://github.com/HansKristian-Work/vkd3d-proton/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/HansKristian-Work/dxil-spirv/archive/${HASH_DXIL}.tar.gz
+ -> dxil-spirv-${HASH_DXIL}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Headers/archive/${HASH_SPIRV}.tar.gz
+ -> spirv-headers-${HASH_SPIRV}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Headers/archive/${HASH_SPIRV_DXIL}.tar.gz
+ -> spirv-headers-${HASH_SPIRV_DXIL}.tar.gz
+ https://github.com/KhronosGroup/Vulkan-Headers/archive/${HASH_VULKAN}.tar.gz
+ -> vulkan-headers-${HASH_VULKAN}.tar.gz
+ "
KEYWORDS="-* ~amd64 ~x86"
fi
@@ -34,12 +43,16 @@ HOMEPAGE="https://github.com/HansKristian-Work/vkd3d-proton/"
LICENSE="LGPL-2.1+ Apache-2.0 MIT"
SLOT="0"
-IUSE="+abi_x86_32 crossdev-mingw debug extras"
+IUSE="+abi_x86_32 crossdev-mingw debug extras +strip"
BDEPEND="
dev-util/glslang
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6-wow64-setup.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
@@ -51,11 +64,11 @@ pkg_pretend() {
eerror "For instructions, please see: https://wiki.gentoo.org/wiki/Mingw"
use abi_x86_32 && use abi_x86_64 &&
eerror "Also, with USE=abi_x86_32, will need both i686 and x86_64 toolchains."
- die "USE=crossdev-mingw is set but ${tool} was not found"
+ die "USE=crossdev-mingw is enabled, but ${tool} was not found"
elif [[ ! $(LC_ALL=C ${tool} -v 2>&1) =~ "Thread model: posix" ]]; then
eerror "${PN} requires GCC to be built with --enable-threads=posix"
eerror "Please see: https://wiki.gentoo.org/wiki/Mingw#POSIX_threads_for_Windows"
- die "USE=crossdev-mingw is set but ${tool} does not use POSIX threads"
+ die "USE=crossdev-mingw is enabled, but ${tool} does not use POSIX threads"
fi
done
tool=-w64-mingw32-widl
@@ -71,12 +84,20 @@ pkg_pretend() {
src_prepare() {
if [[ ${PV} != 9999 ]]; then
- rmdir subprojects/{{SPIRV,Vulkan}-Headers,dxil-spirv} || die
- mv ../dxil-spirv-${DXIL_HASH} subprojects/dxil-spirv || die
- mv ../SPIRV-Headers-${SPIRV_HASH} subprojects/SPIRV-Headers || die
- mv ../Vulkan-Headers-${VULKAN_HASH} subprojects/Vulkan-Headers || die
- ln -s ../../../SPIRV-Headers/include \
- subprojects/dxil-spirv/third_party/spirv-headers || die
+ rmdir khronos/{SPIRV,Vulkan}-Headers subprojects/dxil-spirv || die
+ mv ../dxil-spirv-${HASH_DXIL} subprojects/dxil-spirv || die
+ mv ../SPIRV-Headers-${HASH_SPIRV} khronos/SPIRV-Headers || die
+ mv ../Vulkan-Headers-${HASH_VULKAN} khronos/Vulkan-Headers || die
+
+ rmdir subprojects/dxil-spirv/third_party/spirv-headers || die
+ # dxil and vkd3d's spirv headers sometime mismatch and are incompatible
+ if [[ ${HASH_SPIRV} == "${HASH_SPIRV_DXIL}" ]]; then
+ ln -s ../../../khronos/SPIRV-Headers \
+ subprojects/dxil-spirv/third_party/spirv-headers || die
+ else
+ mv ../SPIRV-Headers-${HASH_SPIRV_DXIL} \
+ subprojects/dxil-spirv/third_party/spirv-headers || die
+ fi
fi
default
@@ -85,25 +106,41 @@ src_prepare() {
if [[ ${PV} != 9999 ]]; then
# without .git, meson sets vkd3d_build as 0x${PV} leading to failure
- sed -i "s/@VCS_TAG@/${VKD3D_HASH::15}/" vkd3d_build.h.in || die
- sed -i "s/@VCS_TAG@/${VKD3D_HASH::7}/" vkd3d_version.h.in || die
+ sed -i "s/@VCS_TAG@/${HASH_VKD3D::15}/" vkd3d_build.h.in || die
+ sed -i "s/@VCS_TAG@/${HASH_VKD3D::7}/" vkd3d_version.h.in || die
fi
}
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # random segfaults been reported with LTO in some games, filter as
+ # a safety (note that optimizing this further won't really help
+ # performance, GPU does the actual work)
+ filter-lto
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
- [[ ! -v MINGW_BYPASS ]] && unset AR CC CXX STRIP WIDL
+ if [[ ! -v MINGW_BYPASS ]]; then
+ unset AR CC CXX RC STRIP WIDL
+ filter-flags '-fuse-ld=*'
+ filter-flags '-mfunction-return=thunk*' #878849
+
+ # some bashrc-mv users tend to do CFLAGS="${LDFLAGS}" and then
+ # strip-unsupported-flags miss these during compile-only tests
+ # (primarily done for 23.0 profiles' -z, not full coverage)
+ filter-flags '-Wl,-z,*' #928038
+ fi
CHOST_amd64=x86_64-w64-mingw32
CHOST_x86=i686-w64-mingw32
CHOST=$(usex x86 ${CHOST_x86} ${CHOST_amd64})
- # preferring meson eclass' cross file over upstream's but, unlike
- # dxvk, we lose static options in the process (from build-win*.txt)
- append-ldflags -static -static-libgcc -static-libstdc++
-
strip-unsupported-flags
fi
@@ -127,7 +164,7 @@ multilib_src_configure() {
--{cross,native}-file="${T}"/widl.${ABI}.ini
$(meson_use {,enable_}extras)
$(meson_use debug enable_trace)
- $(usev !debug --strip) # portage won't strip .dll, so allow it here
+ $(usev strip --strip) # portage won't strip .dll, so allow it here
-Denable_tests=false # needs wine/vulkan and is intended for manual use
)
@@ -138,8 +175,6 @@ multilib_src_install_all() {
dobin setup_vkd3d_proton.sh
einstalldocs
- # unnecesasry files, see package-release.sh
- rm "${ED}"/usr/lib/${PN}/x*/libvkd3d-proton-utils-3.dll || die
find "${ED}" -type f -name '*.a' -delete || die
}
@@ -149,13 +184,24 @@ pkg_postinst() {
elog
elog " WINEPREFIX=/path/to/prefix setup_vkd3d_proton.sh install --symlink"
elog
+ elog "Should also ensure that >=app-emulation/dxvk-2.1's dxgi.dll is available"
+ elog "on it, not meant to function independently even if only using d3d12."
+ elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
+ elif [[ ${REPLACING_VERSIONS##* } ]]; then
+ if ver_test ${REPLACING_VERSIONS##* } -lt 2.7; then
+ elog
+ elog ">=${PN}-2.7 requires drivers and Wine to support vulkan-1.3, meaning:"
+ elog ">=wine-*-7.1 (or >=wine-proton-7.0), and >=mesa-22.0 (or >=nvidia-drivers-510)"
+ fi
+
+ if ver_test ${REPLACING_VERSIONS##* } -lt 2.9; then
+ elog
+ elog ">=${PN}-2.9 has a new file to install (d3d12core.dll), old Wine prefixes that"
+ elog "relied on '--symlink' may need updates by using the setup_vkd3d_proton.sh."
+ elog
+ elog "Furthermore, it may not function properly if >=app-emulation/dxvk-2.1's"
+ elog "dxgi.dll is not available on that prefix (even if only using d3d12)."
+ fi
fi
-
- # don't try to keep wine-*[vulkan] in RDEPEND, but still give a warning
- local wine
- for wine in app-emulation/wine-{vanilla,staging}; do
- has_version ${wine} && ! has_version ${wine}[vulkan] &&
- ewarn "${wine} was not built with USE=vulkan, ${PN} will not be usable with it"
- done
}