summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-0.7.1.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.7.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.7.1.ebuild b/app-eselect/eselect-php/eselect-php-0.7.1.ebuild
deleted file mode 100644
index eba6a7c9d131..000000000000
--- a/app-eselect/eselect-php/eselect-php-0.7.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit depend.apache
-
-DESCRIPTION="PHP eselect module"
-HOMEPAGE="https://www.gentoo.org"
-SRC_URI="https://dev.gentoo.org/~olemarkus/eselect-php/eselect-php-${PV}.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="fpm apache2"
-
-DEPEND=">=app-admin/eselect-1.2.4
- !<dev-lang/php-5.3.23-r1:5.3
- !<dev-lang/php-5.4.13-r1:5.4
- !<dev-lang/php-5.5.0_beta1-r2:5.5
- "
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-want_apache
-
-src_install() {
- mv eselect-php-${PV} php.eselect
- insinto /usr/share/eselect/modules/
- doins php.eselect
-
- if use apache2 ; then
- insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
- newins "${FILESDIR}/70_mod_php5.conf-apache2" \
- "70_mod_php5.conf"
- fi
-
- if use fpm ; then
- dodir "/etc/init.d"
- insinto "/etc/init.d"
- newinitd "${FILESDIR}/php-fpm.init" "php-fpm"
- fi
-}