summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-mesa/eselect-mesa-0.0.10-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-eselect/eselect-mesa/eselect-mesa-0.0.10-r1.ebuild b/app-eselect/eselect-mesa/eselect-mesa-0.0.10-r1.ebuild
new file mode 100644
index 000000000000..f89550fe3b9c
--- /dev/null
+++ b/app-eselect/eselect-mesa/eselect-mesa-0.0.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Utility to change the Mesa OpenGL driver being used"
+HOMEPAGE="https://www.gentoo.org/"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.4
+ >=app-shells/bash-4"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins mesa.eselect
+}
+
+pkg_postinst() {
+ if has_version ">=media-libs/mesa-7.9" && \
+ ! [ -f "${EROOT}"/usr/share/mesa/eselect-mesa.conf ]; then
+ eerror "Rebuild media-libs/mesa for ${PN} to work."
+ fi
+}