summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/honggfuzz/honggfuzz-2.5.ebuild')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-2.5.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-2.5.ebuild b/app-forensics/honggfuzz/honggfuzz-2.5.ebuild
deleted file mode 100644
index db12e6d64274..000000000000
--- a/app-forensics/honggfuzz/honggfuzz-2.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A general purpose fuzzer with feedback support"
-HOMEPAGE="https://honggfuzz.dev/"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="clang"
-
-RDEPEND="
- >=sys-libs/binutils-libs-2.29:=
- sys-libs/libunwind:=
- app-arch/xz-utils
- clang? ( sys-libs/blocksruntime )
-"
-
-DEPEND="${RDEPEND}
- elibc_musl? ( sys-libs/queue-standalone )"
-
-DOCS=(
- CHANGELOG
- COPYING
- CONTRIBUTING.md
- README.md
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0-no-werror.patch
-)
-
-pkg_pretend() {
- if tc-is-clang; then
- use clang || die "${P}: to use clang enable USE=clang for ${P} (bug #729256)."
- fi
-}
-
-src_prepare() {
- default
- tc-export AR CC
- export CFLAGS
- export LDFLAGS
-}
-
-src_install() {
- dobin ${PN}
- dobin hfuzz_cc/hfuzz-cc
-
- einstalldocs
-}