summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/Manifest2
-rw-r--r--app-forensics/afflib/afflib-3.7.1.ebuild64
-rw-r--r--app-forensics/afflib/afflib-3.7.3.ebuild66
3 files changed, 0 insertions, 132 deletions
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
index 9ebb2e1e6b42..3e6a1d280407 100644
--- a/app-forensics/afflib/Manifest
+++ b/app-forensics/afflib/Manifest
@@ -1,3 +1 @@
-DIST afflib-3.7.1.tar.gz 779366 SHA256 7759a36259a070ae087da43a94f23d4026de871e16144d8c32d7b446f5155db2 SHA512 695b5535b7cbe6e1f9b702b40f8606e2dbb604761e2617cc88a61d99f7e296f0dccdf8f21c03bdb79ce5d1fcce543b3d5d23e6bb5c99e31d094e838c16a9443b WHIRLPOOL e6b8c8022cf1405bc4db8697fb20b2e4e21d7b90a3d035acfc56cc6afd742af86d1cffa998903af6ec53b6e370fe8c87e1fcf3188d005c6a7dd56b1cff3ec591
-DIST afflib-3.7.3.tar.gz 569264 SHA256 0bc786efbe4443ee0935eaedf8813d5ba00194dbe8c3340923cb7e38a3120978 SHA512 6c626c01aa8a8a0df47d7a34f14ad25ae818fdf49f142d36a624f747a54cbba88cbf32b8fdb541b37e41b5c28549343e81b4c26b4802299bc6111c6c04cdf6f9 WHIRLPOOL 8775f5e5be09673315002fe5ae74d277c049b109d0d35a2f40af84f68c54d8a9a1b2865e2f792394cbdd403af55e0d7e21f9b3a725d9796d01c855d6c8b26447
DIST afflib-3.7.4.tar.gz 569346 SHA256 74934ae60a76616442f1d593bdeb93dd6aa105b5dc8cee7e8e5d7529a77f46c0 SHA512 58791388a05d614dd5f219a74173de2ff0938a1f93b21e2dd0731aca52ea544ba60cc4325f0d284937467ce600a4302b7a2f724d84710ecc7f12db1a22a8e41c WHIRLPOOL db8d5f48aecc55bd4ee0e6f45552e37e6aa1621674d93a448ae5a5a6b3bba1ae9c40d8aac2211b6e27bf1ba72e1c998b9bb01e6c24298ef4287d7a117db9d820
diff --git a/app-forensics/afflib/afflib-3.7.1.ebuild b/app-forensics/afflib/afflib-3.7.1.ebuild
deleted file mode 100644
index 03f4ce9698da..000000000000
--- a/app-forensics/afflib/afflib-3.7.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-PYTHON_DEPEND="python? 2"
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils python
-
-DESCRIPTION="Library that implements the AFF image standard"
-HOMEPAGE="https://github.com/simsong/AFFLIBv3"
-SRC_URI="mirror://github/simsong/AFFLIBv3/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc x86"
-IUSE="fuse ncurses python qemu readline s3 static-libs threads"
-
-RDEPEND="dev-libs/expat
- dev-libs/openssl:0
- sys-libs/zlib
- fuse? ( sys-fs/fuse )
- ncurses? ( sys-libs/ncurses )
- readline? ( sys-libs/readline:0 )
- s3? ( net-misc/curl )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python-module.patch
- "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
-)
-
-pkg_setup() {
- if use python ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- sed -e '/FLAGS/s: -g::' \
- -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
- -i configure.ac || die
-
- sed -i -e '/-static/d' tools/Makefile.am || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # Hacks for automagic dependencies
- use ncurses || export ac_cv_lib_ncurses_initscr=no
- use readline || export ac_cv_lib_readline_readline=no
-
- local myeconfargs=(
- $(use_enable fuse)
- $(use_enable python)
- $(use_enable qemu)
- $(use_enable s3)
- $(use_enable threads threading)
- )
- autotools-utils_src_configure
-}
diff --git a/app-forensics/afflib/afflib-3.7.3.ebuild b/app-forensics/afflib/afflib-3.7.3.ebuild
deleted file mode 100644
index 90c764a48b87..000000000000
--- a/app-forensics/afflib/afflib-3.7.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
-
-inherit autotools-utils python-single-r1
-
-MY_PN=AFFLIBv3
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Library that implements the AFF image standard"
-HOMEPAGE="https://github.com/simsong/AFFLIBv3/"
-SRC_URI="https://github.com/simsong/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE="fuse ncurses python qemu readline s3 static-libs threads"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="dev-libs/expat
- dev-libs/openssl:0
- sys-libs/zlib
- fuse? ( sys-fs/fuse )
- ncurses? ( sys-libs/ncurses )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0 )
- s3? ( net-misc/curl )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.7.1-python-module.patch
- "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
-)
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- sed -i '/FLAGS/s: -g::' configure.ac || die
- sed -i '/-static/d' tools/Makefile.am || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # Hacks for automagic dependencies
- use ncurses || export ac_cv_lib_ncurses_initscr=no
- use readline || export ac_cv_lib_readline_readline=no
-
- local myeconfargs=(
- $(use_enable fuse)
- $(use_enable python)
- $(use_enable qemu)
- $(use_enable s3)
- $(use_enable threads threading)
- )
- autotools-utils_src_configure
-}