summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/canna')
-rw-r--r--app-i18n/canna/canna-3.7_p3-r1.ebuild26
-rw-r--r--app-i18n/canna/canna-3.7_p3-r2.ebuild24
2 files changed, 1 insertions, 49 deletions
diff --git a/app-i18n/canna/canna-3.7_p3-r1.ebuild b/app-i18n/canna/canna-3.7_p3-r1.ebuild
index 1153ee9dc23d..51effafc6b77 100644
--- a/app-i18n/canna/canna-3.7_p3-r1.ebuild
+++ b/app-i18n/canna/canna-3.7_p3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
inherit cannadic eutils multilib
@@ -19,7 +19,6 @@ DEPEND=">=sys-apps/sed-4
x11-misc/gccmakedep
x11-misc/imake"
RDEPEND=""
-
S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -118,26 +117,3 @@ pkg_postinst() {
elog "You should rebuild app-dict/canna-* after emerge."
elog
}
-
-pkg_prerm() {
- if [ -S /tmp/.iroha_unix/IROHA ] ; then
- # make sure cannaserver get stopped because otherwise
- # we cannot stop it with /etc/init.d after emerge -C canna
- einfo
- einfo "Stopping Canna for safe unmerge"
- einfo
- /etc/init.d/canna stop
- touch "${T}"/canna.cookie
- fi
-}
-
-pkg_postrm() {
- if [ -f /usr/sbin/cannaserver -a -e "${T}"/canna.cookie ] ; then
- #update-cannadic-dir
- einfo
- einfo "Restarting Canna"
- einfo
- /etc/init.d/canna start
- rm -f "${T}"/canna.cookie
- fi
-}
diff --git a/app-i18n/canna/canna-3.7_p3-r2.ebuild b/app-i18n/canna/canna-3.7_p3-r2.ebuild
index 1f4b241bce4a..0f222e9dac21 100644
--- a/app-i18n/canna/canna-3.7_p3-r2.ebuild
+++ b/app-i18n/canna/canna-3.7_p3-r2.ebuild
@@ -26,7 +26,6 @@ DEPEND=">=sys-apps/sed-4
dev-texlive/texlive-latexrecommended
)"
RDEPEND=""
-
S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -141,26 +140,3 @@ pkg_postinst() {
elog
fi
}
-
-pkg_prerm() {
- if [ -S /tmp/.iroha_unix/IROHA ] ; then
- # make sure cannaserver get stopped because otherwise
- # we cannot stop it with /etc/init.d after emerge -C canna
- einfo
- einfo "Stopping Canna for safe unmerge"
- einfo
- /etc/init.d/canna stop
- touch "${T}"/canna.cookie
- fi
-}
-
-pkg_postrm() {
- if [ -f /usr/sbin/cannaserver -a -e "${T}"/canna.cookie ] ; then
- #update-cannadic-dir
- einfo
- einfo "Restarting Canna"
- einfo
- /etc/init.d/canna start
- rm -f "${T}"/canna.cookie
- fi
-}