summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/dbskkd-cdb/dbskkd-cdb-2.00-r1.ebuild')
-rw-r--r--app-i18n/dbskkd-cdb/dbskkd-cdb-2.00-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00-r1.ebuild b/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00-r1.ebuild
deleted file mode 100644
index f63e8826adc0..000000000000
--- a/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="SKK dictionary server based on cdb"
-HOMEPAGE="https://github.com/jj1bdx/dbskkd-cdb"
-SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-DEPEND="|| (
- dev-db/tinycdb
- dev-db/cdb
- )
-"
-
-RDEPEND="
- acct-group/dbskkd
- acct-user/dbskkd
- app-i18n/skk-jisyo[cdb]
- sys-apps/xinetd
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
-
-src_prepare() {
- default
-
- local cdblib=()
- if has_version dev-db/cdb; then
- append-cflags -I"${EPREFIX}"/usr/include/cdb
- local a
- for a in cdb.a alloc.a buffer.a byte.a unix.a; do
- cdblib+=( "${EPREFIX}"/usr/$(get_libdir)/${a} )
- done
- else
- cdblib+=( -lcdb )
- fi
-
- sed -i "/^CDBLIB/s|=.*$|= ${cdblib[*]}|" Makefile
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- COMPAT="-DJISYO_FILE=\\\"${EPREFIX}/usr/share/skk/SKK-JISYO.L.cdb\\\""
-}
-
-src_install() {
- exeinto /usr/libexec
- doexe dbskkd-cdb
- dodoc *.txt
- einstalldocs
-
- insinto /etc/xinetd.d
- newins "${FILESDIR}"/dbskkd-cdb.xinetd dbskkd-cdb
-}