summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild')
-rw-r--r--app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
index aaecf413d372..ff59fdb17065 100644
--- a/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
+++ b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2016-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils gnome2-utils
+inherit cmake xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-sayura.git"
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-sayura"
fi
DESCRIPTION="Sinhala Sayura input method for Fcitx"
-HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-sayura"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-sayura"
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
SRC_URI=""
else
@@ -21,21 +21,21 @@ fi
LICENSE="GPL-2+"
SLOT="4"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+KEYWORDS="amd64 ~hppa ppc ppc64 ~riscv x86"
IUSE=""
-RDEPEND=">=app-i18n/fcitx-4.2.9:4
+BDEPEND="virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
virtual/libiconv
virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${DEPEND}"
DOCS=()
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}