summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/kcc/kcc-1.0.ebuild')
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index 79b890dd7eb6..0aa425112c84 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,33 +1,35 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
-DESCRIPTION="A Kanji code converter"
+DESCRIPTION="Kanji code converter"
HOMEPAGE="http://www2s.biglobe.ne.jp/~Nori/ruby/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
-S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${PN}-gcc3-gentoo.diff
"${FILESDIR}"/${PN}-exit.diff
- "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_configure() {
tc-export CC
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
}
src_install() {
dobin kcc
einstalldocs
- cp -f kcc.jman kcc.1 || die
+ cp kcc.jman kcc.1 || die
doman -i18n=ja kcc.1
}