summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild')
-rw-r--r--app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild b/app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild
index 30d448e19ad9..4eca71e19ee6 100644
--- a/app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild
+++ b/app-i18n/kde-l10n-scripts/kde-l10n-scripts-9999.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/vpelcak/kde-scripts.git"
-[[ ${PV} == 9999 ]] && inherit git-2
+EAPI=6
DESCRIPTION="Set of scripts to manage KDE translation files"
HOMEPAGE="https://github.com/vpelcak/kde-scripts"
-[[ ${PV} == 9999 ]] || SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vpelcak/kde-scripts.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="LGPL-3"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
@@ -26,7 +27,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_prepare() {
+ default
sed -i \
- -e "s:/usr/local:/usr:" \
+ -e "s:/usr/local:${EPREFIX}/usr:" \
Makefile || die
}