summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild')
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..2831d2c6e201
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gucharmap"
+
+RDEPEND=">=app-i18n/scim-1.2.0
+ >=app-i18n/libtomoe-gtk-0.6.0[gucharmap=]
+ gucharmap? ( >=gnome-extra/gucharmap-1.4 )
+ >=x11-libs/gtk+-2.4:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+src_prepare() {
+ # Fix build with gcc-4.3, bug #
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ # Fix build with gucharmap-2.24, bug #243160
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}