summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/batti/batti-0.3.8-r3.ebuild')
-rw-r--r--app-laptop/batti/batti-0.3.8-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-laptop/batti/batti-0.3.8-r3.ebuild b/app-laptop/batti/batti-0.3.8-r3.ebuild
new file mode 100644
index 000000000000..313c72e7044f
--- /dev/null
+++ b/app-laptop/batti/batti-0.3.8-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils eutils
+
+DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
+HOMEPAGE="http://code.google.com/p/batti-gtk/"
+SRC_URI="http://batti-gtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ || ( sys-power/upower sys-power/upower-pm-utils )
+ x11-themes/gnome-icon-theme
+ libnotify? ( x11-libs/libnotify )"
+DEPEND=""
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ has_version ">=sys-power/upower-0.99" && epatch "${FILESDIR}/${P}-upower-0.99.patch"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}