summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/Manifest1
-rw-r--r--app-laptop/thinkfan/metadata.xml2
-rw-r--r--app-laptop/thinkfan/thinkfan-1.0.ebuild45
3 files changed, 48 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
index 3515076cd1c3..0df01627822a 100644
--- a/app-laptop/thinkfan/Manifest
+++ b/app-laptop/thinkfan/Manifest
@@ -1 +1,2 @@
DIST thinkfan-0.9.3.tar.gz 39527 BLAKE2B e6a6d09493d94b4de9ada20dcc4b0251c5f2c148f7faa7f69c04fe2a279a9cfe253a0ea1a01fe94ed108e8731e2ba01edef5df10dfb887ea961a356dff733854 SHA512 d2a29f9cae636c22b66958f8ec50cb60a162d745c3967257bb5e20cc9e152894d4e8a66f897ffa4e49353eba4a42e3499bb9e554719974284089a46cfc6280d7
+DIST thinkfan-1.0.tar.gz 77575 BLAKE2B cc4dfec48d2797079b053b0be923a008b2e740179de10bda549194008a83ce9ea47fdb23e82f0050fa594be81fa07b242b548303fff751845da544f1f8fdd226 SHA512 c85c8a4f3eb2735f065bf56312823a13277b803e4762a325bd250a47f1e35e1efbc45fa63bcd3b2e24184d6f95a9f8d7ceb1b31eb82c674ca2f2f8d57ee0ea30
diff --git a/app-laptop/thinkfan/metadata.xml b/app-laptop/thinkfan/metadata.xml
index e4b22975b67b..c6b8ff4c4c32 100644
--- a/app-laptop/thinkfan/metadata.xml
+++ b/app-laptop/thinkfan/metadata.xml
@@ -7,6 +7,8 @@
</maintainer>
<use>
<flag name="atasmart">include libatasmart support to get disc temperature</flag>
+ <flag name="nvidia">allow thinkfan to read GPU temperature from the proprietary nVidia driver</flag>
+ <flag name="yaml">use YAML format for config file</flag>
</use>
<upstream>
<remote-id type="sourceforge">thinkfan</remote-id>
diff --git a/app-laptop/thinkfan/thinkfan-1.0.ebuild b/app-laptop/thinkfan/thinkfan-1.0.ebuild
new file mode 100644
index 000000000000..d114b72afb16
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils readme.gentoo-r1
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s:share/doc/${PN}:share/doc/${PF}:" \
+ -i CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."