summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-bittorrent')
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild23
-rw-r--r--app-leechcraft/lc-bittorrent/metadata.xml8
2 files changed, 20 insertions, 11 deletions
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
index 4c7602d3f9cb..ecf3e17672e9 100644
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
+++ b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -12,15 +12,20 @@ SLOT="0"
KEYWORDS=""
IUSE="debug geoip"
-DEPEND="~app-leechcraft/lc-core-${PV}
- net-libs/rb_libtorrent"
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ net-libs/rb_libtorrent
+ dev-qt/qtxml:5
+ dev-qt/qtwidgets:5
+"
RDEPEND="${DEPEND}
- virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )"
+ virtual/leechcraft-task-show
+ geoip? ( dev-libs/geoip )
+"
src_configure(){
- local mycmakeargs="
- $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
- "
+ local mycmakeargs=(
+ -DENABLE_BITTORRENT_GEOIP=$(usex geoip)
+ )
cmake-utils_src_configure
}
diff --git a/app-leechcraft/lc-bittorrent/metadata.xml b/app-leechcraft/lc-bittorrent/metadata.xml
index 30c188bbd0e5..ef43617d9e97 100644
--- a/app-leechcraft/lc-bittorrent/metadata.xml
+++ b/app-leechcraft/lc-bittorrent/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
<maintainer type="project">
- <email>leechcraft@gentoo.org</email>
- <name>LeechCraft</name>
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>