summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-blogique/lc-blogique-9999.ebuild')
-rw-r--r--app-leechcraft/lc-blogique/lc-blogique-9999.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/app-leechcraft/lc-blogique/lc-blogique-9999.ebuild b/app-leechcraft/lc-blogique/lc-blogique-9999.ebuild
index a7843149f5ab..974b777f91c0 100644
--- a/app-leechcraft/lc-blogique/lc-blogique-9999.ebuild
+++ b/app-leechcraft/lc-blogique/lc-blogique-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -12,18 +12,26 @@ SLOT="0"
KEYWORDS=""
IUSE="debug +metida +hestia"
-DEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtsql:4[sqlite]
- metida? ( dev-qt/qtxmlpatterns:4 )
- "
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtxml:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtdeclarative:5
+ metida? (
+ dev-qt/qtnetwork:5
+ dev-qt/qtxmlpatterns:5
+ )
+"
RDEPEND="${DEPEND}
virtual/leechcraft-wysiwyg-editor
"
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable metida BLOGIQUE_METIDA)
- $(cmake-utils_use_enable hestia BLOGIQUE_HESTIA)
+ -DENABLE_BLOGIQUE_METIDA=$(usex metida)
+ -DENABLE_BLOGIQUE_HESTIA=$(usex hestia)
)
cmake-utils_src_configure